日本語教師、プログラマーになる。

韓国に嫁いで日本語を教えていましたが、なんやかんやでiOSアプリ作ってます。

cocoapodsのインストールができなかった(未解決)

ライブラリの更新をしようと思って、cocoapodsでやろうと思ったら、まだ入ってなかった。しっぱいしっぱい。と思ってかる〜く始めてみたら、インストールができない!

うおおおお。

 

まずなんかこんなん出た

ERROR:  Error installing cocoapods:

    activesupport requires Ruby version >= 2.2.2.

 

ルビーのバージョンが古いってこと?

222ってなんだよ猫の日かよ

そしたらね、同じので困っている人がいました

 

http://stackoverflow.com/questions/36402189/installing-cocoapods-on-os-x-el-capitan-error

 

うーん?なんか古いバージョンを入れろってかいてある

Cocoapodsは新しいバージョンに対応してないみたいね

というわけでよくわかんないけど言われた通りにやってみる

 

sudo gem install activesupport -v 4.2.6

 

お~っ動いてる動いてる

でもまたエラー><

ERROR:  While executing gem ... (Errno::EPERM)

えぺるむ。。?

 

http://qiita.com/AcaiBowl/items/4bb4708de03e6ee14a4a

 

これでかいけつ~

と思ったら

 

The dependency (ライブラリ名) is not used in any concrete target.

とか言われる。えーっTT

 

どうやらこちらの記事の通りにすれば解決するっぽいけど、そこまでは試してない。期待していらっしゃった方すみません。

qiita.com

 

Cocoapodsは便利だけど、どうやら最近はCarthage(カルタゴ)っていうのがナウいらしいですね。

 

仕事で使いますって言われて途中まで準備したはいいけど、結局Cocoapodsのままで行くことになってそのまま。いつ使うことになるかわからないし…。勉強しておこう。

 

ちなみに、カルタゴ入れようと思って入れたhomebrewは全然別のところで役に立ちました。

iwllgiveitatry.com

 

いや〜人生何が起こるかわからないものです。

このHomebrewは、最初にビールで乾杯?している絵文字が出てくるのが、すごーくカワイイなと思います。